Home » Other » General » sqlplus got stuck while retrieving data from 10g 64bits Solaris
sqlplus got stuck while retrieving data from 10g 64bits Solaris [message #104200] Tue, 17 August 2004 09:32 Go to next message
Hugo Wu
Messages: 1
Registered: August 2004
Junior Member
I have Oracle Database 10g Release 1 (10.1.0.2)
Enterprise Edition installed on Solaris (SPARC, 64-bit),


Here is the table I created


CREATE TABLE "TESTING"
("TYPEID" NUMBER NOT NULL,
 "NAME" NVARCHAR2(256) NOT NULL,
 "SHORTNAME" NVARCHAR2(256) NOT NULL,
 "DESCRIPTION" NVARCHAR2(1024),
 "ATTRIBUTES" NVARCHAR2(256),
 "SYNTAX" NVARCHAR2(256),
 "CREATED" NUMBER NOT NULL,
 "MODIFIED" NUMBER NOT NULL,
 "MODIFIEDUSER" NVARCHAR2(256) NOT NULL,
 CONSTRAINT "PK_TESTING" PRIMARY KEY("TYPEID"),
 CONSTRAINT "UQ_TESTING" UNIQUE("NAME")
);

and it has only one row with 286 characters in "DESCRIPTION" column

BEGIN
INSERT INTO TESTING (TYPEID, NAME, SHORTNAME, DESCRIPTION, ATTRIBUTES, SYNTAX, CREATED, MODIFIED, MODIFIEDUSER)
VALUES (17,
N'Responsible Person',
N'RP',
N'The RP (Responsible Person) record identifies the RPMailbox (domain name that specifies the mailbox for the responsible person), and the TXT Domain (the domain name where the associated TXT resource records exist) of the given domain name. Example: rsmith.testing.com.  rs.testing.com.',
N'10,11',
N'[[RMailbox]] [[Error Mailbox]]',
1092760961,
1092760961,
N'Administrator');
COMMIT;
END;

There is no problem if I run sqlplus to retrieve data on database machine, but it stuck when I try to retrieve data from Windows or Linux by Oracle 10g client (32-bit).

Well, there is no any problems to get data from "Enterprise Management Console" though.

The most weird thing is, my application, which works fine against Oracle8i and Oracle9i with the same table and the same data, gets an error "ORA-01455: converting column overflows integer datatype", when it tries to get data from this table.

Any idea about this ? or is there any configuration I need to setup before fetching data ?

By the way, I have created two databases, they have different "National Character Set", one is UTF8, the other is AL16UTF16, both of them have the same problem.

Thanks in advance.

 
Re: sqlplus got stuck while retrieving data from 10g 64bits Solaris [message #104629 is a reply to message #104200] Fri, 17 December 2004 05:36 Go to previous message
Mike
Messages: 417
Registered: September 1998
Senior Member
We had a very similar problem to yours (i.e. 32 bit client talking to 64 bit solaris server failing when a 64 bit client on the server worked ok) with occasionaly the error message being the same but not always. We mainly got corrupted data via ODBCTest32 or using SQPLus it would just hang. Anyway in the end we got a senario that we could reproduce consistently and submitted it to Oracle.

They refered to Bug 3996621, 'SQLPLUS 10G (WIN) HANGS WHEN RUN QUERY AGAINST ONE SPECIFIC TABLE TO UNIX 10G DB' which I could look at the details for on MetaLink but it wasn't that informative. They also stated this was a duplicate of the bug 3417593, 'PIECEWISE FETCHING OF VARCHAR2 COLUMN FAILED IN SOLARIS CLIENT -> NT SERVER MODE' which I unfortunaely cannot see the details for, shame as I was hoping to understand what exactly was going on.

They very promptly pointed us at the following patch.

The patch number is : 3417593.

This patch is also included in the following patchset : 10.1.0.2.0 Patch 2 (10.1.0.2.2P) 32-Bit <Patch:3768706> 64-Bit <Patch:3768716>

I worked for us so maybe it will help you.

Mike
Previous Topic: Oracle Developer2000
Next Topic: h/w requirements of oracle application server 10g
Goto Forum:
  


Current Time: Fri Dec 09 19:42:50 CST 2022