Home » Infrastructure » Windows » Error connecting to ORACLE 9i on XP from ASP
Error connecting to ORACLE 9i on XP from ASP [message #100646] Fri, 28 March 2003 07:54 Go to next message
Teresa
Messages: 36
Registered: May 2002
Member
Hi,

I got the following error messages when I tried to connect to ORACLE9i(9.2.0.1 for XP, with Ora ODBC driver v9.2.0.2 and Ora provider for OLE DB v9.2.0.2) from ASP pages residing on the same PC.

First Scenario:
Data Source:
MS ODBC for Oracle, connection string "Provider=OraOLEDB.Oracle.1;Data Source=msOracle;User ID=MyID;Password=MyPwd"
Error Type:
Microsoft OLE DB Service Components (0x80070005)
Access is denied.

Second Scenario:
Data Source:
Oracle for Ora92, connection string "DSN=ora1;uid=MyID;pwd=MyPwd"
Error Message:
Microsoft OLE DB Provider for ODBC Drivers (0x80004005)
Specified driver could not be loaded due to system error 5 (Oracle in Ora80).

Neither of the scenarios works now, when both of them worked before on another machine with Oracle server on Linux and client on Win2000.

FYI: User MyID is set to be the admin user on Oracle, and I can successfully connect to Oracle using SQL*Plus and the same user and password. When I test connection from the Data Source configuration window, it was successful.

Please help!!! Thanks!!!

Teresa
Re: Typo-Error connecting to ORACLE 9i on XP from ASP [message #100647 is a reply to message #100646] Fri, 28 March 2003 07:59 Go to previous messageGo to next message
Teresa
Messages: 36
Registered: May 2002
Member
Hi sorry, I found a typo in my message.

In the second scenario, both appearances of the Oracle server name for the data source should be Ora92, not Ora80.

Thanks.
FYI:FIXED-Error connecting to ORACLE 9i on XP from ASP [message #100663 is a reply to message #100646] Mon, 07 April 2003 13:03 Go to previous messageGo to next message
Teresa
Messages: 36
Registered: May 2002
Member
I had to give admin permissions on the oracle direcotry and the subfolders and files to get it to work. Hope this helps people who have the same problem.

Good luck!

Teresa
Re: Error connecting to ORACLE 9i on XP from ASP [message #100732 is a reply to message #100646] Tue, 01 July 2003 14:24 Go to previous messageGo to next message
corey
Messages: 1
Registered: July 2003
Junior Member
what do you mean by giving the oracle user "Admin" permisions? Im having the same error. You give what user what rights on the oracle directoy?
Re: Error connecting to ORACLE 9i on XP from ASP [message #100735 is a reply to message #100732] Tue, 08 July 2003 09:03 Go to previous messageGo to next message
Teresa
Messages: 36
Registered: May 2002
Member
Hi corey,

Basically, I created a user in IIS instead of using the anonymouse user. I gave this user Read, Write, and Execute permisions to Oracle diretory.

Hope this will help.

Best luck.
Teresa
Re: Error connecting to ORACLE 9i on XP from ASP [message #100952 is a reply to message #100646] Wed, 03 March 2004 01:35 Go to previous messageGo to next message
SNNicky
Messages: 1
Registered: March 2004
Junior Member
Introduction:
using IIS and Oracle on the same PC leaded to the Error,
though others PCs in the LAN worked with the same db without any problem.

Opening connections to the same db from stand alone scripts (using wscript) worked fine also.
The data source was defined as System datasource (not User one), so the reason of the error was unclear for me.
-------------------------------------------------

Today I met the same problem (XP sp 1, Oracle9.2)
and tried the suggested solution but slightly modified:

add access for user IUSR_... (account for IIS) to my ora92 folder in <OraHome92> (not for all <OraHome92> as
was suggested) only for
1) Read & Execute
2) List Folder Content
3) Read

That helped.

But some time later I decided to try re-install IIS (because Stop didn't work in ASPs).
When IIS was uninstalled access for IUSR_... became invalid since there was no such user
(was "killed" with IIS).

So I decided to make an experiment and remove teh access rights from ora92 folder again.

After this I installed IIS again.

Just for a joke tried the load the test ASP page with connection.Open
(which leaded to the Error just 10 minutes ago) and ...

There was no error...

I didn't believe and tried to restart the computer.
The test page still worked.

So the solution was either perform 1 successfull call to connection.Open or re-install IIS.
Re: Error connecting to ORACLE 9i on XP from ASP [message #101186 is a reply to message #100735] Tue, 08 June 2004 20:35 Go to previous messageGo to next message
Jaime Flautero
Messages: 1
Registered: June 2004
Junior Member
THANX! THANX THANX THANX!

Thanks a lot for the answer! it Really works!

Muchas Gracias!
icon7.gif  Re: Error connecting to ORACLE 9i on XP from ASP [message #164922 is a reply to message #100646] Mon, 27 March 2006 11:04 Go to previous message
wwu1
Messages: 1
Registered: March 2006
Junior Member
This site is cool and you guys are great. I have searched many other sites and couldn't find any answers that helped. This is the first time I visited orafaq and the first hit solved my problem.

Thank YOU!
Previous Topic: Cannot start Oracle after change server name
Next Topic: ODBC disconnect sporadic
Goto Forum:
  


Current Time: Mon Oct 25 03:30:38 CDT 2021