Home » Infrastructure » Windows » slow oracle connection on windows
icon5.gif  slow oracle connection on windows [message #154501] Mon, 09 January 2006 01:39 Go to next message
druid
Messages: 2
Registered: January 2006
Junior Member
Hi,

The connection time I get for oracle 10 g on windows is between 15-20 seconds Sad for every new connection(from remote as well as local machine) that i make to the oracle database. After the connection everything works fine...

Server Specs:
Freshly installed Oracle 10 g on windows 2000 advanced Server having 2 GB of RAM, 2.6 GHz Processor.

I also like to inform that i got very good connection speed from oracle 10 g(between 1 to 2 seconds) when I installed it on Linux.

My query:
1.Can anybody suggest a way to counter it(15-17 seconds connection time on windows) as, as per my application architecture, I need to frequently connect/disconnect.


Thanks in Advance..
Druid

Re: slow oracle connection on windows [message #154552 is a reply to message #154501] Mon, 09 January 2006 06:42 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10706
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
What kind of installation is than on windows?
did you do a 'default' installation?
may be you are having all those unwanted services installed and autostarted by default ( in windows).
And check your sqlnet/tnsnames/listener.ora files. make sure you no tracing turned on.


Re: slow oracle connection on windows [message #154561 is a reply to message #154552] Mon, 09 January 2006 07:17 Go to previous messageGo to next message
druid
Messages: 2
Registered: January 2006
Junior Member
Hi Mahesh,

Thanks a lot for replying..

Yeah I did a default installation...

And I found out the solution..(I found through the trace file of listener, that the connection was hanging for a long time 15-20 seconds after wait for transport event call ... I googled for the same and found some similar problem and remedy on experts exchange....)

I changed the following line to none instead of NTS in my sqlnet.ora file on the client which solved the problem.. Cool

SQLNET.AUTHENTICATION_SERVICES= (none)

Any comments regarding the above solution are welcome...

Regards,
Druid
Re: slow oracle connection on windows [message #154564 is a reply to message #154561] Mon, 09 January 2006 07:38 Go to previous message
Mahesh Rajendran
Messages: 10706
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>> SQLNET.AUTHENTICATION_SERVICES= (none)
That should be ok.
In most cases ( if you are not using them), you can just comment of that entry.
Previous Topic: schedular in windows
Next Topic: Why ODP.NET could not be installed on 2000 sp4?
Goto Forum:
  


Current Time: Wed Nov 30 11:45:47 CST 2022