Home » Server Options » Data Guard » Automatic database startup issues after switchiver (split from hijacked topic)
Automatic database startup issues after switchiver (split from hijacked topic) [message #682373] Tue, 20 October 2020 16:01 Go to next message
Dusca16
Messages: 5
Registered: October 2020
Junior Member
Dear all,

Sorry for recover this old topic but I'm facing the same issue, my standby never startup automatically in mount mode after a switchover, always related with error: "ORA-12514: TNS: listener does not currently know of service requested in connect descriptor." I always start it layter manually.

Some of you are reporting the observer, but in my opinion in production environment, the FSFO option should be disabled. Switchover and Failover are typical DBA jobs.

I have Data Guard installed in several environments, with exactly the same configuration. This error only happens in some, not all.

Have you found the solution?

Thanks
Re: Automatic database startup issues after SWITCHOVER! [message #682374 is a reply to message #682373] Tue, 20 October 2020 20:00 Go to previous messageGo to next message
BlackSwan
Messages: 26756
Registered: January 2009
Location: SoCal
Senior Member
ora-12514 ALWAYS only occurs due to a problem on DB Server system.
One cause of this problem is when the Oracle database is down & needs to be started.
A remote client send a request to the Listener asking to be connected to a specific service.
If/when the listener does not know anything about that service, the listener responds with ora-12514

post results from the following two OS commands:
lsnrctl status
lsnrctl service

Since every connection request to the listener gets logged, listener.log file will contain a line with 12514 as status code.

This line contains valuable debugging details. So post this line & surrounding lines.

for additional debugging suggestions read the URL below:
http://edstevensdba.wordpress.com/2011/03/19/ora-12514/

Re: Automatic database startup issues after SWITCHOVER! [message #682378 is a reply to message #682374] Wed, 21 October 2020 05:18 Go to previous messageGo to next message
Dusca16
Messages: 5
Registered: October 2020
Junior Member
Dear BlackSwan, thanks for your replay

In fact, "Wait a moment and try to connect a second time" results but my concern is why this standby database takes longer to restart? After exit from sqlplus and try again a couple of times, will be available and I can mount standby...

In alert log, lots of this error:

***********************************************************************

Fatal NI connect error 12518, connecting to:

(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=XXX.YYY)(PORT=1521))(CONNECT_DATA=(SERVER=DEDICATED)(SERVICE_NAME=ZZZ)(CID=(PROGRAM=F:\orac le\product\12.2.0\dbhome_1\bin\ORACLE.EXE)(HOST=XXX)(USER=SRV-ORACLE))))

VERSION INFORMATION:

TNS for 64-bit Windows: Version 11.2.0.3.0 - Production

Windows NT TCP/IP NT Protocol Adapter for 64-bit Windows: Version 11.2.0.3.0 - Production

Time: 20-Oct-2020 18:08:59

Tracing not turned on.

Tns error struct:

ns main err code: 12564

TNS-12564: TNS:connection refused

ns secondary err code: 0

nt main err code: 0

nt secondary err code: 0

nt OS err code: 0

***********************************************************************
Re: Automatic database startup issues after SWITCHOVER! [message #682383 is a reply to message #682378] Wed, 21 October 2020 08:35 Go to previous messageGo to next message
John Watson
Messages: 8426
Registered: January 2010
Location: Global Village
Senior Member
When using Data Guard, you have to define static registrations, a SID_LIST, for the instance and the DG Broker service in your listener.ora file(s). You have not done this, so when you do a switchover the instance de-registers from the listener as it shuts down and the Broker can't reconnect to start it up again.
Re: Automatic database startup issues after SWITCHOVER! [message #682385 is a reply to message #682383] Wed, 21 October 2020 09:24 Go to previous messageGo to next message
Dusca16
Messages: 5
Registered: October 2020
Junior Member
Dear John Watson,

In fact I do not use the _DGMGRL option, I just redefine the LOCAL_LISTENER and STATICCONNECTIDENTIFIER. As I said, this option works for a couple os servers, not for some of them.

ALTER SYSTEM SET LOCAL_LISTENER = '(DESCRIPTION=(ADDRESS=(PROTOCOL=IPC)(KEY=EXTPROC1521)))'

EDIT DATABASE DBPRIMARY SET PROPERTY STATICCONNECTIDENTIFIER='(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=DB1.BLABLA.COM)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=DBPRIMARY)( INSTANCE_NAME=DBPRIMARY)(SERVER=DEDICATED)))';
EDIT DATABASE DBSTANDBY SET PROPERTY STATICCONNECTIDENTIFIER='(DESCRIPTION=(ADDRESS=(PROTOCOL=TCP)(HOST=DB2.BLABLA.COM)(PORT=1521))(CONNECT_DATA=(SERVICE_NAME=DBSTANDBY)( INSTANCE_NAME=DBSTANDBY)(SERVER=DEDICATED)))';

Thanks
Re: Automatic database startup issues after SWITCHOVER! [message #682386 is a reply to message #682385] Wed, 21 October 2020 09:32 Go to previous messageGo to next message
John Watson
Messages: 8426
Registered: January 2010
Location: Global Village
Senior Member
To repeat:

Quote:
When using Data Guard, you have to define static registrations, a SID_LIST, for the instance and the DG Broker service in your listener.ora file(s).
Re: Automatic database startup issues after SWITCHOVER! [message #682388 is a reply to message #682386] Wed, 21 October 2020 10:33 Go to previous messageGo to next message
Dusca16
Messages: 5
Registered: October 2020
Junior Member
Indeed John Watson

SID_LIST_LISTENER =
(SID_LIST =
(SID_DESC =
(SID_NAME = CLRExtProc)
(ORACLE_HOME = F:\oracle\product\12.2.0\dbhome_1)
(PROGRAM = extproc)
(ENVS = "EXTPROC_DLLS=ONLY:F:\oracle\product\12.2.0\dbhome_1\bin\oraclr12.dll")
)
(SID_DESC =
(GLOBAL_DBNAME = DBPRIMARY)
(ORACLE_HOME = F:\oracle\product\12.2.0\dbhome_1)
(SID_NAME = DBPRIMARY)
)
)

LISTENER =
(DESCRIPTION_LIST =
(DESCRIPTION =
(ADDRESS = (PROTOCOL = TCP)(HOST = DB1.BLABLA.COM)(PORT = 1521))
(ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
)
)

LOGGING_LISTENER_NAME=ON
Re: Automatic database startup issues after SWITCHOVER! [message #682391 is a reply to message #682388] Wed, 21 October 2020 11:03 Go to previous messageGo to next message
Michel Cadot
Messages: 67543
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Before your next post, Please read How to use [code] tags and make your code easier to read.

Re: Automatic database startup issues after SWITCHOVER! [message #682403 is a reply to message #682391] Thu, 22 October 2020 05:36 Go to previous messageGo to next message
Dusca16
Messages: 5
Registered: October 2020
Junior Member
Thanks Michel Cadot but I can't edit my oun post Sad
Re: Automatic database startup issues after SWITCHOVER! [message #682412 is a reply to message #682403] Thu, 22 October 2020 11:01 Go to previous message
Michel Cadot
Messages: 67543
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

This is why I said "for your next post".

Previous Topic: Recover Physical Standby Database Error
Goto Forum:
  


Current Time: Fri Nov 27 08:37:14 CST 2020