Home » Server Options » Data Guard » Unable to connect stand by (Oracle 11g R2 Windoes)
Unable to connect stand by [message #680060] Mon, 20 April 2020 13:57 Go to next message
rajesh_b
Messages: 20
Registered: December 2019
Junior Member
 I am trying to set up a stand by environment in Windows Environment with Oracle 11g

Hi,

I am getting the error 
Error 1033 received logging on to the standby
PING[ARC1]: Heartbeat failed to connect to standby 'to_standby'. Error is 1033.

Please help

Re: Unable to connect stand by [message #680061 is a reply to message #680060] Mon, 20 April 2020 14:06 Go to previous messageGo to next message
Michel Cadot
Messages: 67560
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
ORA-01033: ORACLE initialization or shutdown in progress
 *Cause: An attempt was made to log on while Oracle is being started up
         or shutdown.
 *Action: Wait a few minutes. Then retry the operation.
Your standby is not started.
Re: Unable to connect stand by [message #680062 is a reply to message #680061] Mon, 20 April 2020 14:38 Go to previous messageGo to next message
rajesh_b
Messages: 20
Registered: December 2019
Junior Member
When I checked I am unable to connect the stand by server from primary and Vise versa. But I can do tns ping
I have password file in both servers

Re: Unable to connect stand by [message #680064 is a reply to message #680062] Mon, 20 April 2020 14:49 Go to previous messageGo to next message
John Watson
Messages: 8428
Registered: January 2010
Location: Global Village
Senior Member
Is the standby mounted? tnsping does nothing more than contact the listener.

[Updated on: Mon, 20 April 2020 14:50]

Report message to a moderator

Re: Unable to connect stand by [message #680065 is a reply to message #680062] Mon, 20 April 2020 14:50 Go to previous messageGo to next message
BlackSwan
Messages: 26757
Registered: January 2009
Location: SoCal
Senior Member
OS Services for both database & the listener must be started & UP before the STARTUP command will succeed on Windows.
Re: Unable to connect stand by [message #680066 is a reply to message #680065] Mon, 20 April 2020 14:58 Go to previous messageGo to next message
rajesh_b
Messages: 20
Registered: December 2019
Junior Member
 Standby is mounted and all the services are started and Up 
Re: Unable to connect stand by [message #680067 is a reply to message #680066] Mon, 20 April 2020 15:07 Go to previous messageGo to next message
Michel Cadot
Messages: 67560
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

This must be true from the primary database instance(s) Oracle home to the standby.
Prove your claims and show us how you did check this.

[Updated on: Mon, 20 April 2020 15:07]

Report message to a moderator

Re: Unable to connect stand by [message #680068 is a reply to message #680067] Mon, 20 April 2020 15:25 Go to previous messageGo to next message
rajesh_b
Messages: 20
Registered: December 2019
Junior Member
Primary
-----------------------------------------------------------------------------
Service "arietest" has 1 instance(s).
  Instance "arietest", status READY, has 1 handler(s) for this service...
Service "arietestXDB" has 1 instance(s).
  Instance "arietest", status READY, has 1 handler(s) for this service...
The command completed successfully
------------------------------------------------------------------------------
Able to connect to Primary as sysdba
>sqlplus sys/arietest@arietest as sysdba
--------------------------------------------------------------------------------
Unable to connect to standby from primary

ERROR:
ORA-01017: invalid username/password; logon denied
---------------------------------------------------------------------------------

Standby
-------------------------------------------------------------------------------
Service "standby" has 1 instance(s).
  Instance "arietest", status READY, has 1 handler(s) for this service...
The command completed successfully
---------------------------------------------------------------------------------
Able to connect to standby db from standby server
:\Windows\system32>sqlplus sys/arietest@arietest as sysdba

----------------------------------------------------------------------------------
Unable to connec to primary from standby

ERROR:
ORA-01017: invalid username/password; logon denied
----------------------------------------------------------------------------------

Re: Unable to connect stand by [message #680069 is a reply to message #680068] Mon, 20 April 2020 16:15 Go to previous messageGo to next message
John Watson
Messages: 8428
Registered: January 2010
Location: Global Village
Senior Member
Copy your password file across. Just having the same password isn't enough. Trust me.

Apart from that, it looks horribly confused: you seem to be using the same tnsnames alias of arietest for both databases, which I would say is a recipe for disaster. If you show your listener.ora files, your tnsnames.ora files, and your spfiles, it might become clear.
Re: Unable to connect stand by [message #680074 is a reply to message #680069] Tue, 21 April 2020 00:50 Go to previous messageGo to next message
rajesh_b
Messages: 20
Registered: December 2019
Junior Member

Primary


LISTENER =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = RIE-OTEST-VM.arg.internal)(PORT = 1521))
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    )
  )
-------------------------------
tns

ARIETEST =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = RIE-OTEST-VM.arg.internal)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = arietest)
    )
  )

to_standby=
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 10.100.101.20)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = standby)
    )  )
-----------------------
spfile changes made

log_archive_dest_1='location=C:\LogRep'
log_archive_dest_2='service=to_standby'
standby_file_management=auto
-----------------------------------------

Standby

Listener
SID_LIST_STANDBY =
  (SID_LIST =
    (SID_DESC =
      (SID_NAME = CLRExtProc)
      (ORACLE_HOME = D:\app\oradbadmin\product\11.2.0\dbhome_1)
      (PROGRAM = extproc)
      (ENVS = "EXTPROC_DLLS=ONLY:D:\app\oradbadmin\product\11.2.0\dbhome_1\bin\oraclr11.dll")
    )
  )

ADR_BASE_STANDBY = D:\app\oradbadmin

STANDBY =
  (DESCRIPTION_LIST =
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = TCP)(HOST = 10.100.101.20)(PORT = 1521))
    )
    (DESCRIPTION =
      (ADDRESS = (PROTOCOL = IPC)(KEY = EXTPROC1521))
    )
  )
-------------------------------
tns
ARIETEST =
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = 10.150.11.93)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = arietest)
    )
  )

to_standby
  (DESCRIPTION =
    (ADDRESS = (PROTOCOL = TCP)(HOST = RIE-ICDBDR)(PORT = 1521))
    (CONNECT_DATA =
      (SERVER = DEDICATED)
      (SERVICE_NAME = standby)
    )  )
-------------------
SPFILE
*.db_unique_name='standby' (standby)
standby_archive_dest='C:\LogRep'

I am trying to create the standby only no failover

Re: Unable to connect stand by [message #680075 is a reply to message #680074] Tue, 21 April 2020 01:14 Go to previous message
John Watson
Messages: 8428
Registered: January 2010
Location: Global Village
Senior Member
There are so many things wrong in those files that I see no chance of fixing it all. You need to start again.

What document are you following? Clearly, not Oracle's Data Guard documentation.
Previous Topic: oracle instance naming in a dataguard setup
Next Topic: Recover standby after losing sync
Goto Forum:
  


Current Time: Wed Dec 02 19:51:33 CST 2020