Home » RDBMS Server » Server Administration » Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 (Oracle Grid Infrastruture, 12.1.0.2.0, Windows 2012 64-bit)
Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669931] Thu, 24 May 2018 21:20 Go to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Hi,

I am trying to upgrade Oracle Grid Infrastruture from 12cR1 to 12cR2.

The update wizard complains that following patches are missing from grid home.

19234907
21255373

However, when I try to apply these patches, I get the following error.

Oracle Interim Patch Installer version 12.2.0.1.13
Copyright (c) 2018, Oracle Corporation. All rights reserved.


Oracle Home : D:\App\GridInfra\product\12.1.0\grid
Central Inventory : C:\Program Files\Oracle\Inventory
from :
OPatch version : 12.2.0.1.13
OUI version : 12.1.0.2.0
Log file location : D:\App\GridInfra\product\12.1.0\grid\cfgtoollogs\opatch\opat
ch2018-05-25_12-15-55PM_1.log

Verifying environment and performing prerequisite checks...
Skip patch 21255373 from list of patches to apply: This patch is not needed.

After skipping patches with missing components, there are no patches to apply.
OPatch Session completed with warnings.
Log file location: D:\App\GridInfra\product\12.1.0\grid\cfgtoollogs\opatch\opatc
h2018-05-25_12-15-55PM_1.log

This is content of the log file.

[25/05/2018 12:15:55 PM] [INFO] CUP_LOG: Trying to load HomeOperations object
[25/05/2018 12:15:55 PM] [INFO] CUP_LOG: HomeOperations provider not available
[25/05/2018 12:15:55 PM] [INFO] CUP_LOG: This is unusual state. HomeOperations object is null, but it should not be null if HomeOperations create went thru. CUP is not available
[25/05/2018 12:15:55 PM] [INFO] OPatch invoked as follows: 'apply '
[25/05/2018 12:15:55 PM] [INFO] Runtime args: [-DOPatch.ORACLE_HOME=D:\App\GridInfra\product\12.1.0\grid, -DOPatch.DEBUG=false, -DOPatch.RUNNING_DIR=D:\App\GridInfra\product\12.1.0\grid\OPatch, -DOPatch.MW_HOME=, -DOPatch.WL_HOME=, -DOPatch.COMMON_COMPONENTS_HOME=, -DOPatch.OUI_LOCATION=, -DOPatch.FMW_COMPONENT_HOME=, -DOPatch.WEBLOGIC_CLASSPATH=, -DOPatch.OPATCH_CLASSPATH=]
[25/05/2018 12:15:55 PM] [INFO] Heap in use : 20 MB
Total memory: 245 MB
Free memory : 224 MB
Max memory : 3641 MB
[25/05/2018 12:15:55 PM] [INFO] Oracle Home : D:\App\GridInfra\product\12.1.0\grid
Central Inventory : C:\Program Files\Oracle\Inventory
from :
OPatch version : 12.2.0.1.13
OUI version : 12.1.0.2.0
OUI location : D:\App\GridInfra\product\12.1.0\grid\oui
Log file location : D:\App\GridInfra\product\12.1.0\grid\cfgtoollogs\opatch\opatch2018-05-25_12-15-55PM_1.log
[25/05/2018 12:15:55 PM] [INFO] Patch history file: D:\App\GridInfra\product\12.1.0\grid\cfgtoollogs\opatch\opatch_history.txt
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-TIME] Loading raw inventory
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-MEMORY] Loaded all components from inventory. Heap memory in use: 43 (MB)
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-MEMORY] Loaded all one offs from inventory. Heap memory in use: 43 (MB)
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-TIME] Raw inventory loaded successfully
[May 25, 2018 12:15:57 PM] [INFO] NApply::no CAS enabled, OPatch runs with legacy process.
[May 25, 2018 12:15:57 PM] [INFO] Verifying environment and performing prerequisite checks...
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-TIME] Running prerequisite checks
[May 25, 2018 12:15:57 PM] [INFO] opatch-external.jar is in D:\App\GridInfra\product\12.1.0\grid\OPatch\jlib\opatch-external.jar
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-TIME] Loading cooked inventory
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-MEMORY] : Loading cooked one offs. Heap memory used 46 (MB)
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-MEMORY] : Loaded cooked oneoffs. Heap memory used : 46 (MB)
[May 25, 2018 12:15:57 PM] [INFO] [OPSR-TIME] Cooked inventory loaded successfully
[May 25, 2018 12:15:57 PM] [INFO] Checking conflict among patches...
[May 25, 2018 12:15:57 PM] [INFO] Running prereq checkConflictAmongPatchesWithDetail
[May 25, 2018 12:15:57 PM] [INFO] Following patches can be applied: 21255373
[May 25, 2018 12:15:57 PM] [INFO] Following patches are not required:
[May 25, 2018 12:15:57 PM] [INFO] Following patches are auto rollbackable:
[May 25, 2018 12:15:57 PM] [INFO] Finished checking prereq checkConflictAmongPatchesWithDetail
[May 25, 2018 12:15:57 PM] [INFO] Conflict checking amongst patches PASSED
[May 25, 2018 12:15:57 PM] [INFO] Checking if Oracle Home has components required by patches...
[May 25, 2018 12:15:57 PM] [INFO] Skip patch 21255373 from list of patches to apply: This patch is not needed.
[May 25, 2018 12:15:57 PM] [INFO] CheckMissingComps: Cached file does not exist or is invalid, re-build prereq result.
[May 25, 2018 12:15:57 PM] [WARNING]OUI-67124:
After skipping patches with missing components, there are no patches to apply.
[May 25, 2018 12:15:57 PM] [INFO] UtilSession: N-Apply done.
[May 25, 2018 12:15:57 PM] [INFO] --------------------------------------------------------------------------------
[May 25, 2018 12:15:57 PM] [INFO] The following warnings have occurred during OPatch execution:
[May 25, 2018 12:15:57 PM] [INFO] 1) OUI-67124:
After skipping patches with missing components, there are no patches to apply.
[May 25, 2018 12:15:57 PM] [INFO] --------------------------------------------------------------------------------
[May 25, 2018 12:15:57 PM] [SEVERE] OUI-67008:OPatch Session completed with warnings.
[May 25, 2018 12:15:57 PM] [INFO] Finishing UtilSession at Fri May 25 12:15:57 AEST 2018
[May 25, 2018 12:15:57 PM] [INFO] Log file location: D:\App\GridInfra\product\12.1.0\grid\cfgtoollogs\opatch\opatch2018-05-25_12-15-55PM_1.log

Any ideas anyone?
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669933 is a reply to message #669931] Fri, 25 May 2018 00:00 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Quote:
After skipping patches with missing components, there are no patches to apply.
There are no problems then.

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669934 is a reply to message #669933] Fri, 25 May 2018 00:35 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Michel Cadot wrote on Fri, 25 May 2018 10:00

Quote:
After skipping patches with missing components, there are no patches to apply.
There are no problems then.

Yes but the upgrade to 12cR2 is complaining that these patches are missing.
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669936 is a reply to message #669934] Fri, 25 May 2018 00:41 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Not in your post.

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669938 is a reply to message #669936] Fri, 25 May 2018 00:57 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
/foru/forum/fa/13847/0/
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669939 is a reply to message #669938] Fri, 25 May 2018 00:58 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
I have uploaded the screenshot.
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669940 is a reply to message #669939] Fri, 25 May 2018 01:02 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Then click on "Ignore all".

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669941 is a reply to message #669940] Fri, 25 May 2018 01:08 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Michel Cadot wrote on Fri, 25 May 2018 11:02

Then click on "Ignore all".

Yes already tried that, it says 'Some mandatory prerequisites are not met. These prerequisites cannot be ignored.'
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669942 is a reply to message #669941] Fri, 25 May 2018 01:15 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Post log.

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669943 is a reply to message #669942] Fri, 25 May 2018 01:29 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Michel Cadot wrote on Fri, 25 May 2018 11:15

Post log.

Any idea where I can find installer logs on Windows?

The installation hasn't even begun yet, it's stuck on prerequisites check.
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669944 is a reply to message #669943] Fri, 25 May 2018 01:50 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
I'm just wondering why the installer is asking for these patches, when Opatch says there's no need to install them?
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669945 is a reply to message #669943] Fri, 25 May 2018 02:08 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Search for "install*.log" in "progam files\oracle" and Oracle home.

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669947 is a reply to message #669944] Fri, 25 May 2018 02:09 Go to previous messageGo to next message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator
hammad83 wrote on Fri, 25 May 2018 08:50
I'm just wondering why the installer is asking for these patches, when Opatch says there's no need to install them?
Wild guess: installer just searches for patch numbers whereas OPatch searches if there are components to patch with these patches.

Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669948 is a reply to message #669931] Fri, 25 May 2018 02:33 Go to previous messageGo to next message
John Watson
Messages: 8455
Registered: January 2010
Location: Global Village
Senior Member
Shouldn't you be removing those patches, not installing them?
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669976 is a reply to message #669948] Sun, 27 May 2018 19:07 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
John Watson wrote on Fri, 25 May 2018 12:33
Shouldn't you be removing those patches, not installing them?
Nope, see attachment.
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #669977 is a reply to message #669947] Sun, 27 May 2018 19:08 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Michel Cadot wrote on Fri, 25 May 2018 12:09
hammad83 wrote on Fri, 25 May 2018 08:50
I'm just wondering why the installer is asking for these patches, when Opatch says there's no need to install them?
Wild guess: installer just searches for patch numbers whereas OPatch searches if there are components to patch with these patches.

Ok so, any ideas how to get past these patch checks?
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #670019 is a reply to message #669931] Wed, 30 May 2018 00:05 Go to previous messageGo to next message
hammad83
Messages: 46
Registered: June 2008
Location: Australia
Member
Ok I found a solution, for anyone else running into this issue.

Open command prompt navigate to the grid software directory.

Run "gridsetup -skipPrereqs" and it will skip the prereqs and continue with the installation.

I think you should first just run gridSetup without skipping prereqs and see if there are any other errors than missing patches.

Even if it complains about missing patches, first try to apply these patches in grid home.

However, if the Opatch says that these patches are not needed, then you can run the setup without prereqs check as mentioned above.
Re: Upgrading Oracle Grid Infrastructure from 12cR1 to 12cR2 [message #670020 is a reply to message #670019] Wed, 30 May 2018 00:26 Go to previous message
Michel Cadot
Messages: 67640
Registered: March 2007
Location: Nanterre, France, http://...
Senior Member
Account Moderator

Thank you for your feedback and solution.

Previous Topic: Not able to connect using SID
Next Topic: oracle user does not see some data
Goto Forum:
  


Current Time: Tue Jan 19 05:57:33 CST 2021