Home » Server Options » Replication » ROWVERSION data type not getting replicated - Golden Gate (SQL Server 2008 R - Oracle Golden Gate 11.2.1)
ROWVERSION data type not getting replicated - Golden Gate [message #630673] Fri, 02 January 2015 08:37
Messages: 134
Registered: November 2011
Location: Canada
Senior Member

We are replicating data from "SQL Server 2008 R" to "Oracle - on Linux X64", using Oracle Golden Gate 11.2.1

we have mapped ROWVERSION data type on Source (sql server) with RAW(200) on Oracle (target)

However after replication the ROWVERSION values aren't replicating properly on the target
for example
"0x00000000000547C4" on source appear as "00000000000547C4" on the target system

I tried using conversion functions in Golden gate - binary, bintohex,hextobin, in the replicat parameter file

Also I tried using "before insert trigger" on the target - :new.<column_name>:=rawtohex(:new.<column_name>)

But not getting the hex value from the source as it is!

Could anybody please suggest

Thanks and Regards
Previous Topic: Oracle Golden Gate - Initial Load - File Method
Next Topic: Oracle Golden Gate -Replication - RAW to BLOB
Goto Forum:

Current Time: Wed Jan 27 07:31:06 CST 2021