Home » RDBMS Server » Backup & Recovery » Backups are not created in FRA (Oracle 10g R2 on Linux)
Backups are not created in FRA [message #485624] Thu, 09 December 2010 03:10 Go to next message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
Hi,

I am using Oracle 10.2.0.4.0 on Linux

I am testing my backup script and policy on test database

I have configured the flash recovery area as follows

SQL> show parameter recovery

NAME                                 TYPE        VALUE
------------------------------------ ----------- ------------------------------
db_recovery_file_dest                string      /u04/oradata/db2fra
db_recovery_file_dest_size           big integer 1G
recovery_parallelism                 integer     0


and following is my backup script

run{
allocate channel ch1 device type disk format '%d_%T_%s_%p.bak';
crosscheck archivelog all;
delete expired archivelog all;
configure retention policy to redundancy 2;
backup database plus archivelog;
delete noprompt obsolete;
}


I was assuming all backups will be created in the FRA but instead backups are created in $ORACLE_HOME/dbs directory

Do I need to explicitly mention the complete FRA path in the backup script?

Thanks and Regards,
Chetanaz
Re: Backups are not created in FRA [message #485626 is a reply to message #485624] Thu, 09 December 2010 03:33 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10694
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
post your RMAN configuration settings.
Re: Backups are not created in FRA [message #485627 is a reply to message #485626] Thu, 09 December 2010 03:36 Go to previous messageGo to next message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
Hi Mahesh

Thanks for the quick reply

Following are the details

Only the snapshot controlfile configuration is pointing to $ORACLE_HOME/dbs

RMAN> show all;

using target database control file instead of recovery catalog
RMAN configuration parameters are:
CONFIGURE RETENTION POLICY TO REDUNDANCY 2;
CONFIGURE BACKUP OPTIMIZATION OFF; # default
CONFIGURE DEFAULT DEVICE TYPE TO DISK; # default
CONFIGURE CONTROLFILE AUTOBACKUP ON;
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F.bck';
CONFIGURE DEVICE TYPE DISK PARALLELISM 1 BACKUP TYPE TO BACKUPSET; # default
CONFIGURE DATAFILE BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE ARCHIVELOG BACKUP COPIES FOR DEVICE TYPE DISK TO 1; # default
CONFIGURE MAXSETSIZE TO UNLIMITED; # default
CONFIGURE ENCRYPTION FOR DATABASE OFF; # default
CONFIGURE ENCRYPTION ALGORITHM 'AES128'; # default
CONFIGURE ARCHIVELOG DELETION POLICY TO NONE; # default
CONFIGURE SNAPSHOT CONTROLFILE NAME TO '/opt/oracle/product/102/dbs/snapcf_db2.f'; # default


Thanks and Regards,
Chetanaz
Re: Backups are not created in FRA [message #485641 is a reply to message #485627] Thu, 09 December 2010 04:27 Go to previous messageGo to next message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
Hi Mahesh

Do you want me to provide any other information on the issue described?

Regards,
Chetanaz
Re: Backups are not created in FRA [message #485643 is a reply to message #485627] Thu, 09 December 2010 04:47 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10694
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
$ORACLE_HOME/dbs is the default area.
Seems your channel allocations within the run command script is diverting RMAN from FRA.
Remove that line and try again.
Re: Backups are not created in FRA [message #485650 is a reply to message #485643] Thu, 09 December 2010 05:07 Go to previous messageGo to next message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
Thanks Mahesh

As you suggested I removed the following line
allocate channel ch1 device type disk format '%d_%T_%s_%p.bak';


And executed the backup script
And now the backup generated at FRA location (except controlfile backup as expected)
Too good!

Later I issued following command before I execute the backup script again
RMAN> configure channel device type disk format '%d_%T_%s_%p.bak';

and again executed the backup script as above without following line in the script
allocate channel ch1 device type disk format '%d_%T_%s_%p.bak';


but now the backup created at $ORACLE_HOME/dbs as I observed in my first attempt.

So bottomline is If I remove the 'allocate channel' as you have suggested then backup is created at FRA but I can't cusromize the format of backup pieces then

Thanks and Regards,
Chetanaz


Re: Backups are not created in FRA [message #485653 is a reply to message #485650] Thu, 09 December 2010 05:13 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10694
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator
>>backup is created at FRA but I can't cusromize the format of backup pieces
You don't want to. Oracle uses OMF for FRA files.
Re: Backups are not created in FRA [message #485658 is a reply to message #485653] Thu, 09 December 2010 05:29 Go to previous messageGo to next message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
That's great!

Thanks Mahesh

Last question in this thread:

Do I need to customize backup of controlfile to FRA or it is general practice to leave it at $ORACLE_HOME/dbs which is default location for it?

Thanks and Regards,
Chetanaz
Re: Backups are not created in FRA [message #485659 is a reply to message #485658] Thu, 09 December 2010 05:44 Go to previous messageGo to next message
Mahesh Rajendran
Messages: 10694
Registered: March 2002
Location: oracleDocoVille
Senior Member
Account Moderator

As already said,
$ORACLE_HOME/dbs is the default location for backups (datafiles and controlfiles).
If you want to use FRA, then just don't add any customization (formats etc) because FRA will use OMF. Then all your backups
will go to FRA.
From your settings,
CONFIGURE CONTROLFILE AUTOBACKUP FORMAT FOR DEVICE TYPE DISK TO '%F.bck';

This might push your controlfile to $ORACLE_HOME/dbs even though you are using FRA.
Re: Backups are not created in FRA [message #485668 is a reply to message #485659] Thu, 09 December 2010 06:28 Go to previous message
chetanaZ
Messages: 132
Registered: October 2009
Location: UK
Senior Member
Thanks Mahesh

Its clear to me now

Regards,
Chetanaz
Previous Topic: Need to reproduce live server backup on test machine
Next Topic: Recovery of icremantal backup without deleting the previous backup
Goto Forum:
  


Current Time: Sun Mar 07 22:22:03 CST 2021