Home » RDBMS Server » Backup & Recovery » RMAN-06429: TARGET database is not compatible with this version of RMAN
RMAN-06429: TARGET database is not compatible with this version of RMAN [message #483055] Thu, 18 November 2010 00:14 Go to next message
AviatoR
Messages: 43
Registered: February 2009
Member

when i'm trying to connect through RMAN for backup it is showing these following errors:-

oracle_rman1> rman catalog rman/rman target sys/admin@exeo555

Recovery Manager: Release 10.2.0.3.0 - Production on Thu Nov 18 11:29:31 2010

Copyright (c) 1982, 2005, Oracle. All rights reserved.

Recovery Manager incompatible with TARGET database: RMAN 8.0.4.0 to 9.2.0.0 required
RMAN-00571: ===========================================================
RMAN-00569: =============== ERROR MESSAGE STACK FOLLOWS ===============
RMAN-00571: ===========================================================
RMAN-00554: initialization of internal recovery manager package failed
RMAN-06429: TARGET database is not compatible with this version of RMAN
Re: RMAN-06429: TARGET database is not compatible with this version of RMAN [message #483056 is a reply to message #483055] Thu, 18 November 2010 00:19 Go to previous messageGo to next message
John Watson
Messages: 8501
Registered: January 2010
Location: Global Village
Senior Member
You need to run the RMAN executable from the target database home. It looks as though you are running it from the catalog database home?
Re: RMAN-06429: TARGET database is not compatible with this version of RMAN [message #483069 is a reply to message #483056] Thu, 18 November 2010 01:41 Go to previous messageGo to next message
girish.rohini
Messages: 744
Registered: April 2005
Location: Delhi (India)
Senior Member
HI

@John
I am sorry to disagree but I think we can run rman executable from anywhere and not necessarily from target Db home only so long it is one of the versions mentioned in error message

"Recovery Manager incompatible with TARGET database: RMAN 8.0.4.0 to 9.2.0.0 required"
Here in this case RMan executable is 10.2.0.3

Please correct me if I am wrong here.

@Aviator
Please refer http://download.oracle.com/docs/cd/B19306_01/backup.102/b14194/compat002.htm for RMAN compatibility matrix.
Also refer to http://atozoracle.blogspot.com/2009/04/rman-06429-target-database-is-not.html

--Girish

[Updated on: Thu, 18 November 2010 01:48]

Report message to a moderator

Re: RMAN-06429: TARGET database is not compatible with this version of RMAN [message #483078 is a reply to message #483069] Thu, 18 November 2010 04:03 Go to previous message
John Watson
Messages: 8501
Registered: January 2010
Location: Global Village
Senior Member
update: I can't read this morning. I'm going to delete this whole post.

[Updated on: Thu, 18 November 2010 04:32]

Report message to a moderator

Previous Topic: Can we recover archived logs from new backups
Next Topic: backup script
Goto Forum:
  


Current Time: Sun Mar 07 21:47:00 CST 2021